网络服务
 
信息服务
 
网络安全
 
下载专区
 
常见问题
 
通知公告
 
管理制度
 
新闻信息
 
分类服务
 
服务指南
 
快速通道
WordPress论坛插件bbPress存在存储型XSS漏洞

发布日期:2017-05-18  作者:

WordPress论坛插件bbPress存在存储型XSS漏洞 

 

 

摘自:Frebuff.com
  近日,WordPress母公司Automattic发布了bbPress  2.5.9版本,在这个官方的WordPress论坛插件的最新版本中,修复了一个威胁程度较高的存储型XSS漏洞,影响范围包括现有的bbPress版本,即版本< 2.5.9的皆会受到影响。
  根据来自WordPress.org的统计数据,当前已有超过  30万站点使用了该插件。而据悉,该漏洞是一个存储型XSS漏洞,此类漏洞与反射型XSS漏洞,并称为XSS的两大类型漏洞。我们知道,在存储型XSS漏洞中,攻击者可以利用漏洞于Web平台中植入恶意代码,而恶意代码会被存储于后台或数据库中,随后其他用户访问受影响页面时,便会执行攻击者此前植入的恶意代码,从而实现跨站的攻击。
  该XSS  漏洞存在于插件的用户提及功能中,一开始来自Sucuri的安全研究人员称其发现一种方法,攻击者通过用户提及功能(即@用户名,而bbPress的用户提及功能能够将@用户名替换成另外一个链接,创建了一个嵌套链接的HTML结构。),可在论坛文章中存储恶意代码。而这些文章会被存在到数据库中,后面会展示给随后的访问者。如果攻击者有着更加成熟的技术,可通过这种方法从版主或者管理员处窃取cookies,以管理员身份进行操作,实现提权。